n every loud click. It’s OK when pulling backwards, sprays and vacuums up water. Belt appears OK. Thanks
Bissell 1699 ProHeat Clear View Upright Steam Vacuum

How to Identify and Fix Common Vacuum Problems ?

Our sources include academic articles, blog posts, and personal essays from experienced Vacuum Technicians :

If your machine is making an abnormally loud noise it is likely due to the belt slipping or the brush roll being incorrectly installed, follow these steps to resolve: Turn off and unplug machine. Use a Phllips-head screwdriver to remove 3 screws, 2 in the belt cover and 1 on the brush roll mount. Remove belt cover.
This machine uses HeatWave Technologyâ„¢ which helps maintain consistent water temperature throughout the cleaning process by redirecting the heat of the motor to help maintain the temperature of the water.
If you find that your CleanView vacuum is hard to push, you may need to adjust the height adjustment dial. The highest setting should be used for high pile and most shag carpet.
Most carpet cleaning pros say they use a range of 100-400 psi for regular carpeting, but some use a psi as high as 500 for standard jobs. For more delicate fabrics, such as thinning cotton or nylon, you may need to go as low as 50 psi.

Relevant Questions and Answers :

the most relevant questions and answers related to your specific issue

My Bissell Proheat 12 amp is hard to push forward(whether on or off). There is a loud clicking noise when pushing forward and it ”jumps” up on every loud click. It’s OK when pulling backwards, sprays and vacuums up water. Belt appears OK. Thanks
ANSWER : I had this same problem and here is what solved it for me. On a previous cleaning session, my wife decided to take the two front screws out of the clear plastic shroud that covers the brushes in order to clean behind it. Upon re-installation, she did not secure the top part correctly. On the end near the water tank, there are two tiny half-moon tabs that absolutely need to be seated in their opposing slots in the chassis.This allows for a good seal which enables the machine to **** up the water. It also keeps the front cover level and from dragging on the carpet when pushing it forward. Both were problems I was experiencing. Hope this helps!

Hi my proheat bissell 7901 stopped pumping water to the floor, but it pumps water from the hand hose. I read the manual and followed how to check belt and the flat belt on right side of shampooer is fine and I turned on and it turns and so do the brushes at the bottom of the machine. I was reading online and I guess there’s two belts on this machine? where can I find the other belt to see if it needs replacing. I guess it’s a ribbed belt? that is the water pump belt?
ANSWER : Just taken ours apart with the same problem… found it was caused by the 2 halves of the main casing coming apart in the area where the upright pedal release is. I found this to be due to the upper casing having broken in 2 places – the bottom of the screw wells..This means that the water tank cannot exert sufficient pressure on the valve to release the water..Only solution is a new top cover assembly

The original belt on my upright Kenmore Progressive broke and I replaced it with the spare that was in the vacuum. The vacuum and spare belt are about 10 years old. Then the spare broke after one vacuuming session and there was a burning smell coming from the vacuum. I ordered new belts and replaced it with the new belt. It seems to be working fine with no smell. I checked the belt after I vacuumed the family room and although it was in tact, the belt was very hot. Is that normal? Should t
ANSWER : The belt heats up due to the friction, as well as being in contact with the shaft of a hot motor. It is normal.

I have a bissell quickwash 1950-e. I bought it Jan. 2006, and have only used it 8-10 times, I live in a very hard water area, so I though if I put some vinegar in with the cleaning solution it would get rid of any hard water deposits, unfortunatly the solution went lumpy in the tank and stoped spraying out water, I have opened it, hose clean, sprayer not blocked, x at bottom of water container when depresed water trickles out, component that opens the x when water container placed, also ran wate
ANSWER : Hard to say what is causing your problem, replacing the cap and insert on the water tank may help, part #2041111, even tho it may trickle out water when depressed, they can still be bad. The other thing would be the rod not relesing the water like it should. The big draw back to this model is Bissell has obsoleted all of its parts and most are no longer available. Might be wiser to buy new.

Hoover WindTunnel Self-Propelled V Belt
ANSWER : I had this same problem with the V belt on my Hoover Vaccuum..
.There are three (3) basic things that will cause the brush roll not to spin..
.1. When handle is upright, brush roll is OFF..2. When switch is set for HARD surface, brush roll is OFF..3. Broken/worn FLAT belt or V Belt, brush roll will not spin.
.
.I noticed that the brush roll was not spinning when my vacuum was set for CARPET. After removing the cover I noticed that the V belt was loose, I thought the belt was worn so I purchased a correct replacement belt and installed it, but the new belt was also loose and when I turned the large flat belt pulley it did not turn the V belt pulley at the same time..
.I double checked the surface setting and I had the vacuum switch set for carpet, but still when I released the handle out of the upright position the brush roll would still not spin..
.My aggravation finally led me to this posting on FixYa’s website..
.The first thing I did was checked the screw to the left of the V belt as suggested by ejmjr5 and this did nothing to solve the problem or create more tension on the V belt, even when the upright handle was not in the upright position..
.After playing around with the surface setting control switch/nob I notice that when I moved the switch out of the HARD surface setting and over to CARPET, I had thought that the switch was set for CARPET as it visually appeared, but I was not pushing the switch over hard enough to click it into the CARPET setting mode..
.VOILA, the brush roll now spins correctly even though the V belt seams to be too loose for the pulley..
.You really have to force the switch into the CARPET setting. Be sure that you hear the switch/nob click into place..
.Now you can effectively clean up after that hangover of a party!.
.Burp!

Hi folks,
my beam vacuum makes a very loud roaring noise quite often.
the problem started when i was vacuuming up a quantity of vermiculite from my chimney.
i think i overloaded the vacuum i think and it made this loud roaring noise.
the vacuum tends to make thos noise when i am hoovering after 5 minutes or so.
any ideas?.
thanks in advance Tom….
ANSWER : If the filter bag is bad and didn’t trap all of the dust, then it got into your motor, so you may have a problem with your motor now.

Loud noise I have a brand new Dyson and it is great on all my floors except one of my area rugs when it starts making this really loud vibrating noise. I am not sure why – nothing is stuck in the roller or vacuum and it doesn’t make it on any of my other rugs. Also it is really hard to push whereas all the other floors it just glides. I don’t want to return it but I also don’t want to hear this sound every time I vacuum.
ANSWER : This is the clutch as it jams up in the brush. Usually happens with rugs that are not secured to the floor.

I purchased a brand new Eureka Pet vacuum, sorry don’t know exact name but it the one that has the self cleaning duster on it. Last night I used the vacuum on my carpet, it was working fine until I accidently sucked up the corner of a scarf that was hanging off a couch. I shut the vacuum off, pulled out the scarf and and resumed vacuuming. Much to my dismay the suction on the vacuum had ceased. Can you tell me if there is a reset button on the vacuum? The vacuum does not appear to be damage
ANSWER : If the motor is running, there should be suction. Possible problems depend on whether it’s a canister or upright and are:
.A clog in the hose, UR or canister. Detach hose. Drop small coin in one end and lift hose causing it to roll out the other. If it does, no clog in hose. Drop same coin into hose opening on power head. If it rolls out, no clog in PN.
.Broken fan blades, UR. Needs to be taken to shop for repair/replacement.
.
.A reset button is for use if the motor isn’t running, so won’t have anything to do with the suction.