Hoover SteamVac F5914-900 SpinScrub Upright Vacuum\015 The machine wont even start. I have tried several outlets where other appliances work, but nothing.\015

How to Identify and Fix Common Vacuum Problems ?

Our sources include academic articles, blog posts, and personal essays from experienced Vacuum Technicians :

Check the Rotator Brush and Wheels

Sometimes pieces of string or other objects get wrapped around your vacuum`s rotating brush or around the wheels of the vacuum. Unplug your vacuum. Turn it over and have a look at the wheels and brush. If you see any pieces of string or objects lodged there, remove them.

Check that the vacuum cleaner is plugged into a working power outlet and that fuses and breakers don`t need resetting. An activated thermal cut-out due to a blockage is the next most likely cause of the problem. Check for blockages in the hose and filters, and remove any obstructions that you find.
Inspect the vacuum hose for any small holes, kinks, or cracks. Any cracks or holes will decrease the amount of suction in the hose and will not allow the carpet extractor to properly remove liquid from the floor. The hose will need to be replaced if there is damage.
Check to see if the collection water tank outside the bladder is full. The float will activate to cut off suction. Empty the collection tank and test for suction. If there is still no suction at this time, please visit a BISSELL Authorized Service Center.
Although Hoover of course recommend their own detergent, we are using a 50/50 mixture of white vinegar and water, with a few drops of essential oil (tea tree oil) in it to improve the fragrance. This has worked well for us and is very inexpensive.

Relevant Questions and Answers :

the most relevant questions and answers related to your specific issue

Power nozzle not working on my vac but does on another vac
ANSWER : If pushing the reset button doesn’t help try having your local Aerus dealer check out the 2 prongs in the power head where it all connects. Sometimes they go bad.

Hoover u5781-900, motor shuts off (intermittent)when you shake vac or make jerky movements.If you move vac to up right position the vac starts right up.When you giggle vac, motor starts and stops no mater if you just started up or vac for ran for 45 min. Thanks Lucy C.
ANSWER : Lucy
.you have a bad connection somewhere in the unit
.this is a fire hazard and you should not use this until its been fixed
.could be a pinched wire or broken connections

The power brush floor rug attachment on my Eureka 6997 A Oxygen Canister Vacuum goes on an off as I use it. I replaced the The power cord from the handle has 2 plug in connections:
1 at the handle / upper wand
1 at the lower wand top of the power brush attachment

I replaced the entire wand assembly and it worked great for a year or so and now it’s doing the same thing again. I was told to keep the power switch on the handle set to off when connecting the power brush attachment or it will bu

ANSWER : This is from the prongs not making a good connection causing an arch inside the plugg causing what looks like rust on the plugg. I would try snugging up the connection by squeezing the female section to get a better connection on the prongs when it is plugged in together.

Power head attachment works great when plugged into the hose part of the vacuum. The problem is when I attach it to the tube for normal use there is no power. I have checked all the connections and switched the power switch on and off still no power from tube to power head.
Is there anything else I can try? Model Callisto
ANSWER : Try having someone turn the machine on and off while you pull the cord in and out with the cord more angled towards the on/off switch. Sometimes these models have a break in the cord rewind and will not put the power through to the motor.

Keep in mind this is repairable, and if the unit is less than 5 years old it should still be under warranty.

Good luck .

I have a miele S712 (2 yrs old worked fine yesterday) – I had been doing some diy work inside and had the vac on just to reduce some of the dust in the air – after a while the vacuum fizzled out. I guessed it had overheated and took it outside to cool down – when I tried to turn it back on pressing the power button gives it power and it starts to **** but it won’t STAY on, soon as you release the power button it stops, and the orange bag indicator is showing full. As I have a compressor I took
ANSWER : You have got dust in the micro switch and it is not latching on, if you look at this and clean it, that will solve your problem, however blowing the motir has probably wrecked the motor bearings.

No power i try to turn it on no power i treid different power source no luck check everything no power
ANSWER : It could be the switch button that you push to turn it on (2031199), or the switch (2031243) could be the problem. If not those 2, then the cord could be bad or even the motor (2031214). I would check that switch button first.

MY VACUUM ISN’T PULLING AS STRONG AS IT USED TO SO I THINK IT NEEDS A NEW BELT. I CAN’T FIND THE MANUEL ON IT SO I NEED SOME INSTRUCTIONS ON HOW TO CHANGE THE BELT. I DON’T WANT TO BREAK MY VAC. CAN SOME ONE PLEASE INSTRUCT ME ON HOW I SHOULD CHANGE THE BELT PLEASE. TYPE VAC: EUREKA THE BOSS WHIRLWIND LITE CYCLONIC POWER CANISTER TYPE VAC. THE HANDLE IS DETACHABLE TO CLEAN IN THE CORNER WITH A SMALL EXTENSION.
ANSWER : You can get Eureka replacement belts here:

Eureka Vacuum Betls

Power cord can not find replacement power cord for power brush attachment on kenmore canister vacuum, model #2491290 power brush attachment model # 5491290. i can not even find those model #’s anywhere online, not even partsdirect.com. any help would be great. thanks, david
ANSWER : Call 1-800-948-1358 ask for Buck mon.-fri. 9am-5pm est sat.9am-1pm est